THE ECLIPSEPROJECT

References

The following slides are extracted from
» a courseware which is part of the Open
Source “"ECESIS” project

» The courseware is produced by, and is
copyrighted by Espirity, Inc. and CMA

» To get the whole course material go to
> http://www.eclipse.org/ecesis/

» the Eclipse Project FAQ page

» Basic tutorial by Adam Kiezun
> http://www.eclipse.org/
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Module Road Map

=  Overview
* Background

*  Architecture
* Components

= Usage scenarios

* Installing and Running
=  Workbench
*  Building and Running Java Classes
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What is Eclipse?

» Eclipse is an open source project
» http://www.eclipse.org
» Consortium of companies
including Borland, IBM, Rational, Red Hat
» Launched in November 2001
» Designed to help developers with specific development
tasks
» Consists of three separate projects:
» Eclipse Project
» Eclipse Tools Project
» Eclipse Technology Project
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The Eclipse project

» The Eclipse Project is an open source software
development project dedicated to providing a robust
platform for the development of highly integrated
tools.

» It is composed of three subprojects:
» Platform,
» JDT - Java development tools,

» PDE - Plug-in development environment.
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The Eclipse Tools Project

» The mission of Eclipse Tools Project is to foster the
creation of a wide variety of tools for the Eclipse
Platform.

» The Tools Project provides point of coordination for open
source tool developers in order

> to minimize overlap and duplication,
> ensure maximum sharing and creation of common components,

> and promote seamless interoperability between diverse types
of tools.

» The Tools project is composed of subprojects which are
proposed, selected and developed by the community of tool
developers and the Tools Project PMC.
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The Eclipse Technology Project

» The mission of the Eclipse Technology Project is to
provide new channels for open source developers,
researchers, academics and educators to participate
in the on-going evolution of Eclipse.

» It is organized as three related project streams

» Research: explore research issues in Eclipse-relevant
domains such as programming languages and development
environments;

» Incubators: small, informally structured projects which add
new capabilities to the Eclipse software base;

» Education: projects focus on the development of
educational materials, teaching aids and courseware.
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The Eclipse SDK

» The Eclipse SDK (software development kit) is the
consolidation of the components produced by the
three Eclipse Project subprojects

» Platform,
» JDT - Java development tools,
» PDE - Plug-in development environment
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IBM’s IDE History The Eclipse Platform Motivation

Application development tools construction support
GUI and non-GUI application development support

Numerous content types support
» Java, HTML, C, C++, XML, ...

v

1994
VisualAge for Smalltalk

v

v

Easy integration of tools
1996 N Use of Java language for writing the tools
VisualAge for Java :> Isualge Hicro Edition Multiple operating systems support

v

v

v

1l
2001

Eclipse Project
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Plug-in Architecture Workbench

» Represents the desktop [

e Refactor Navigste Search Project Run Window Hel

Eclipse Platform - Tool development AR Box- 0 88080 | v
= (plug-in) environment - = Fow
Workbench S— » It contains set of tools for R ———
- TOOI resource management To get started, read the sections below and dlick.o
=D (plug-in) » It provides common way * R e o
of navigating through the § | a”
resources = S
Workspace » Multiple workbenches
can be opened at the _
- T00| same tlme == :
': (plug-in)
Platform Runtime
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» Represents users data
» It is a set of user defined resources

» Files B
» Contain arbitrary number of bytes _ > e 5P

» Folders T MySerlet
~ Contain other folders or files EQ Pt

» Projects
> Collections of files and folders
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How is Eclipse Used?

» As an IDE - Integrated Development
Environment
» Used for writing code

» As a product base

» Supported through plug-in architecture and
customizations
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Eclipse as an IDE

» Java Development Tool (JDT) is used for
building Java code
» Provides set of workbench plug-ins for
manipulating Java code
» Java projects, packages, classes, methods, ....
» Java compiler is built in
» Used for compiling Java code

» Creates errors (special markers of code) if
compilation fails
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Eclipse as a Product Base

» Eclipse can be used as a Java product base
» Its flexible architecture used as a product
framework
» Reuse plug-in architecture
» Create new plug-ins
» Customize the environment

A Berief Introduction to Eclipse Project 16




Module Road Map

= QOverview

= Installing and Running Eclipse
=  Where to get Eclipse?
*  What is the support for Eclipse?
= Installing Eclipse

* Running Eclipse

=  Workbench
*  Building and Running Java Classes

A Berief Introduction to Eclipse Project 17

Getting Eclipse

icrosoft Internet Explorer =lalx|
Ei Tools  Help “Links &]Customize Links & ] Free Hotmail

deBack » = A G| @search (Favorites cHristory |5 S - 1H ¥ 2D
Address [&] http . sclipse, org =] e
Google - facipse history 18 | Epsearchweb  @ysearchsite | §lnews | @Page Info -

J
J
J
J

feclipse

home

consortium - —a
ol eclipse.org
downloads
articles i SRS Nt atured eolipss oomer atlicles — "
Newsgroups
ma\'liﬂg_‘lisls:
community Welcome to eclipse.org
Eclipse is a kind of universal tool platform - an open extensible IDE
search for anything and nothing in patticular. Find out what eclipse is all
bugs about - check out the white paper (requires Acrobat Reader 4.0 or
later), read some technical artticles, visit the newsgroups, take a
look at the projects, and pick up the latest downloads. Don't forget x|
& || |8 mtemet 7
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http://www.eclipse.org

» Main point for finding Eclipse resources
» Downloads
» Articles
» Discussion groups
» Bugs
» Contains various resources for using Eclipse

» Contains references to other Eclipse related
sites
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Downloading Eclipse’s Install Zip File

» Click on the Download from the main page
on http://www.eclipse.org

» Choose the closest site from which to download
(geographical sites hosting the download)

» Choose the build for download (usually the latest
build)

» Choose the platform for download and type of
download (http or ftp)

» Specify where to save the download locally
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Installing the Eclipse

» Unzip the downloaded file to the directory of
your choice

(] winzip - eclipse-SDK-2.1-win32.zip § — (ol x|
File Actions  Options  Help

@@@ﬁ%@%ﬂ

Mew Open Favarites Add Extract Wit CheckOut

Nome © [ Type [ Modfied  ~

MU hitespaceDetoctor . java | JAVA File 3{27/2003
(S ¥MLTagscanner java JAVA File 34272003 ¢

bl eeerac 2
7] X

5] mLPartitionSeanner.java FZET
5] smlParseraPls jar Exfract to: Falders/diives: [ Eaet |
(S =MLDaUbleClickstrateqy.java ﬁ Bl _>| =[] Deskion

[l ¥MLDocumentProvider. java = ‘=58, My Computer Cancel

@ #MLConfiguration.java e 3% Floppy [4:)

Dxercessrc.zip © Seletediies Lacal Disk (C:) Help

5] ercesimpl.jar & Allfles Compact Disc (0]

wr\te_uzi_d\:abled.gwf Cores [ - ﬁnrpalftp[‘)isn i8]

o write_obj.gi B Iy Metwork Places

= .

workset_wiz.gif gy Computers Near Ms

S T Duwenwnite existing files o g My Dixcuiments
I Skip alder files
Selected 0 files, 0 bytes [t Usefolder names Hew Folder
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eclipse.exe

» Eclipse is run by double-clicking on the
eclipse.exe file

» The file is located in the Eclipse installation
directory

» If there is no path set for javaw.exe program,
the following dialog will come up

Eclipse x|

A Java Runtime Environment (JRE) or Java Development Kit (JDK)
must be availabls in order to run Eclipse, Mo Java virkual machine
was Found after searching the Following locations:

i eclipseliraibin|javaw. sxe

avaw.exe'in your current PATH
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Missing a Java VM? ...

» Download the latest Java Runtime
Environment (JRE), e.g., v1.4.1_02 from
http://java.sun.com/j2se/

» Click on the downloaded EXE file to install

» When given the option by the installer,
identify a directory of your choice for the
install files

» Update the PATH environment variable to
include the JRE’s bin directory
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... Missing a Java VM?

» Other VMs are available at the Eclipse download
web site

&l
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Specifying JVM

» There are two ways of specifying JVM for
Eclipse:
» By installing JVM under the \jre\ directory off the
eclipse install directory

» By specifying existing JVM in the PATH
environment variable
Start -> Control Panel -> System ->Advanced -> Environment Variables

Edit System Variable L 2|
‘ariable Name: [Path
Yariahle Yalus: | L1BYSAMPLESIREPL; e YjcKijdk! .3.1_08bin]
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Running Eclipse

» When Eclipse is run, a Workbench opens
=10l

Fle Edt Navigste Search Froject Run Window Help

S -REs|% | ¢%
| esivovigater ~ x |[FREEE x|
= : | ® <= ||Eclipse Platform

-
iThis page will help Familiarize you with the Eclipss Workbench, =
To get started, read the sections below and click on the related links.
(® Installed Features
To find oLt more abolt ths features installed in your workbench, cf
and select the Feature you are interested in.

(® Perspectives, views and editors
22 Outine o A window contains one or more perspectives. & perspective consisl
and editors For working with your resources. =

#An outline is not available,

4 | »
37 Tasks (0 items) b S
| ] ¢ [ Description | Resource [ inFold
< | »
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Module Road Map

= QOverview
* Installing and Running

= Workbench

= Basics
* Resources
= Components
* Perspectives, Views and Editors

Specialized Views

Customization

*  Building and Running Java Classes
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Default Workspace

» The default workspace is created when
Eclipse runs for the first time

» The workspace is located under \workspace\
directory of Eclipse installation directory

» For example c:\eclipse\workspace
» The workspace contains user defined data -

projects and resources such as folders and
files
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Running Different Workspace What is the Workbench?

» It is possible to run workspace other than » Starting point for the development with Eclipse
default » Opens up when Eclipse starts

» -data argument must be used with eclipse.exe » Represents the working environment in Eclipse

£ Resource - Welcome - Eclipse Platform =10l x|
» Workspace location must be specified e e
» Useful for grouping project specific data e T
1o x] Uitttz
CC5 Cauright 1985 1099 Wickasase Corp. Lot Ty TR
C:~rcd eclipse = and selact the feature you are interested in.
C:veclipseXeclipse —data c:“my_project workspace A:tnuf\lw:in:nntavaﬂah\a‘x 4| = = = — | Ll;‘
:FI I'algk!s:DD:_T;ti_n_n |Resnu::; ﬁi\?Fn;Erx
4 | »
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Multiple Workbench Instances Resources in a Workbench
» Instance of the workbench comes up when » When working with Eclipse, you work with its
Eclipse launched resources
> %iskpbossi?lle to open another instance of the » Resources are organized as a file/directory
orkbenc

structure in the Workbench

» They correspond to the actual files and directories
in the Workspace

» Window > New Window
» This opens up a new Workbench window
» This is important when developing Eclipse plug-

ins and you want to test them within the » There are three different levels on resources:
environment > Projects
> When testing plug-ins new instance of Workbench opens > Folders

with developed plug-ins > Files
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Organizing Resources

£= Resource - myFile.txt - Eclipd

File Edit MNawigate Search  Proj

project —
[F-HE S| % ~lojx]
_J_-Bng\t View Favortes Tools Help ‘_
5. Mavigator X i1 | @search [ hroders sty |05 T ¢ 7
folder\@ \ _ y | :u: -%}x;:, eclpselwarkspace\MyFirstProject{MyFolder = @6 ‘

N b MyFirstProject
E\I_#[B MyFaolder

LB myFile bt
file b =] project

& My Computer 7

Workbench Workspace
= It is possible to drag and drop resources directly
between Workbench and the directory structure
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Importing Resources
[Emport ]

» Available through s '3
menu option File >
Import...
» Different source of -
resources can be Frete
imported:

» Existing projects
» Files (directory

structure)
» Zip files
= Back: | hext= | Fiiyisty I Cancel |
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Exporting Resources

T
» Available through e £’
menu option File > v
Export... s
» Different source of [
resources can be B
exported:
» File (directory structure)
» Zip files
» Jar files
e |
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Refreshing Workbench

» Used for refreshing resources that change in
the Workspace directly

» For example, if file is added to the directory
structure in the Workspace:
» Select the project

» Choose Refresh from the context menu
» This will bring the added resource into the Workbench
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Resource History

» All resource versions are stored in local history

» Each resource version is identified by a time stamp

» This allows you to compare different versions of the
resource

» There are two pop-up menu options available for
accessing local history (the resource is selected):
» Compare With > Local History...
» Replace With - Local History...
» Both options bring up the same window
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Comparing Files

» Allows you to view differences between
different versions
» You can move between differences
» Differences are selected

£ Compare with Local History S ]

[E] Local History of myFile kxt!

@Y Today (Sep 20, 2003) -
[ROF 45517 P

@ 4:1%:30 PM |

[E] Text Compare T

Warkspacs Fils
Version2
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Workbench Components

» Workbench contain perspectives
» Perspective contain views and editors

me - Eclipse Platform 1o x|
e E & Search Project Run indow Help
|5~ AIEEEZES
perspective = = x| Bweone x|
[Bo = [ # 4 ||Eclipse Platform
d t This pags will help familiarize vou with the Eclipse warkbench. ﬂ
editor P> To get started, read the sections below and dlick on the related ks
b 4
) Installed Features
To Find out more about the features installed in your workbench, choose
and select the feature you are interested in,
2= Outline x i
. A outling Is not avaiable. 4] = = = — | ¥
VIEWS P | 57| Tasks (0 tems) G 2w x
\ | v |t | Description | Resowrce | 1nFoider
I
4| | »
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» Perspective defines initial layout of the views
in the Workbench

» They are task oriented, i.e. they contain
specific views for doing certain tasks:
» Java Perspective for manipulating Java code
» Resource Perspective for manipulating resources
» Debug Perspective for debugging applications

» One Workbench window contains many
perspectives
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Opening Perspective

» It is possible to open a

perspective:

> In a Same WOFkbenCh Ele Edit Mavigate Search Project Bun MWindow Help
window [B5-B86 %] 9] X -

» In a new Workbench [ B e
window

» Perspective can be open
by:
» Choosing Window - Open "

PerSpeCt'Ve menu option An outline is not avalable. i
» Clicking on a perspective ¥ T O
shortcut button PRl

| >

4

MyFirstProject
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Available Perspectives

» By default, the following perspectives are
available in the Workbench:

£-Select Perspective il

liCys Reposiory Exploring |
Debug

&@Install,l’LIpdate
Java

S\'J Java Browsing

TzJJava Type Hierarchy

== Plug-in Develapment

IéﬁResnurca {default)
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Saving Perspective

» Arrangement of views and editors 5
Can be mOdIfled and Saved for Enter or selact a nams ta save the currant

perspective as.

perspectives

» Choose Window - Save Perspective as ...
to Save perspeCtlve %CVSRepus\toryExp\uring

» Perspective can be saved under a new [¥x

?p@ Install/Update

Iame: i MyPerspective|

Existing Perspectives:

(use-defined perspectives) or an el
existing name T30 Type Herarchy

<0 Plug-in Development

» You can also reset perspective to (aresouee (it
original arrangement
» Choose Window - Reset Perspective...
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Customizing Perspectives

» Available for current perspective

» Allows customization such as menu items and
views
i

Select the it=ms to be displayed in the current perspective (Resource),

Available Ttems: Details:

f

- dass

O convert Java to Plug-in Projects
- [ Extension Foint Schema

[ Feature Project

File

Folder

O Fragment Project

O tnterface

O 3ava Project.

Dl Package

O Plug-in Praject.
[ Project
O serapbock Page.
- [ Saurce Falder
O restcase
- [ Testsuite
O Update Sits Praject
Window > Open Perspective
A Cvs Renositary Explarina |

e
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Deleting Perspectives

» Only user-defined
perspectives can be
deleted

» To delete perspective:

Choose Window - Preference

>

» Extend Workbench category —

» Select Perspectives 2 ;

st fjupdate nstalUpdote
» Select perspective for e, —
deleting = - -

» Click Delete e —
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» An editor for a resource opens when you double-
click on a resource

» Editor type depends on a type of the resource, for example
.txt files are open with the text editor
» When an editor opens on a resource, it stays open across
different perspectives
> When perspectives change editor stays open
» Active editor contains menus and toolbars specific to that
editor

» When you change a resource, an asterisk on the editor’s
title bar indicates unsaved changes
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Editors and File Types

» It is possible to

S

associate an editor | T =5

with a file type o i

» Choose Window > . _mene|
Preferences %j”i :I

» Select File E
Associations e =l

» Select file type A

» Click Add to B SR LI
associate it with an = o —
editor el e |
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Views...

» The main purpose of a view is:
» To support editors
» To provide alternative presentation and
navigation in the Workbench
» Views can have their own menus and
toolbars

» Items available in menus and toolbars are
available only in that view
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\Views

» Views can:
» Appear on their own
» Appear stacked with other views

» Layout of the views can be changed by
clicking on the title bar and moving views

» Single views can be moved together with other
views

Adding Views to Perspective

» To add a view to the
current perspective: A
» Choose Window - Open | R

= Properties

Perspective > Other... s e
» The Show View window % & oo

G Java

{Z= JavaBrowsing
comes up el
{5 PDE Runtime

» Select window to be shown i Tean

{5 Update Manager

[ &-showview x|

» Stacked views can be moved to be single views > Click OK
Ed
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Stacked Views Fast Views...

£ MyPerspective - myFile.txt - Eclipse Platform o [m] 1]

Eile Edit Mavigate Search Project Run ‘Window Help

|[F-BEE %[ %% &~
IF | [esinavigator || JWekome  [ElmFlent X

@ N Versionz 4
El-{mh MyFirstProject
-G MyFolder
i) anotherFile b
5) mryFile.txt

| | »

5= Outline x _'l_l

W Eoe x

An outline is not available,

! | Description | Resource | In Foldar

4| | »
Taske Bookmarks

0 items: O tasks, 0 ervors, Wgs, Oinfos

» Stacked views appear in a notebook form
» Each view is a notebook page
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» Hidden views that can be quickly
opened and closed Fast View

» They take up space in the

£ MyPerspective - myFile.txk — Ecli
Eile Edit/ Mavigate Search Project

Workbench s f e & [[= - [ =
» Fast views can be created by: Y | [ navigater == |l
» Dragging an open view to the /0 L 1= % I
shortcut bar = B e
» Selecting Fast View from the o B BEAE
view’s menu 2l i
» Fast View is activated by clicking on | & siee s e svaissie: | =
its Fast View pop-up menu option %‘i
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» Click on the Fast View opens the view in the
current perspective

Specialized Views

» Some of the most commonly used views in

Eclipse are:
» Click outside of the view makes it hidden » Navigator View
again e _ i » Bookmark View
E » Task View
2 » Search View
» These views display specific information
e
zzzji’TR.hn.ulLJ e
| |
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feclipse
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» Used for displaying

_ B — » Displays all tasks
{'ﬁsoﬂ;ces r']n the & = | = £ » Tasks associated with the resources
or _enc _ _ _ B » Generic tasks
2 Golle =l Gl e e AL §y Compiler errors that occur during the
of the resources B e g P 9
B project development
» Also used for _
manipulating resources LES R
| 2 Edlting g%lu It later mMVF\rstPro]ect)’MyFolder
» Import/Export
» Refactoring
i | »l
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Adding Tasks

» Tasks usually indicate action
for the resource

» Associated with resources
> With lines in a file
> Generlc ~ | Welcome |myFi|e.txt b4
» To add a task:

» Pop-up the menu on a lin
in the editor

» Choose Add Task...
» To delete task:

» Pop-up the menu

» Choose Delete Task...

-
i
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Bookmarks View

» To add a bookmark on a line in a file:
» Pop-up the menu on a line in the editor
» Choose Add Bookmark...
» Bookmarks View displays all bookmarks
available
» Allows manipulation of the bookmarks
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Adding Bookmarks

» Bookmarks are used as markers for:
» Resources
» Lines in a file

» To add a bookmark on a resource:
» Pop-up menu on a resource in the Navigator
view
» Choose Add Bookmark...
» Specify bookmark name

- x
» Click OK =

Enter hookmark name:

Cancel
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» Eclipse comes with an
extensive Search

[ Fie search | 2 Help search | [ Java Sesrch | % Plug-in Search |

m e C h a n I S m ﬁ::::;\; = =] ¥ case senstive
» You can search for entities (. T ——
such as files, text, and Java T T
Cl asses 'r:::::ams are separated by comma (* = any string, 7 = any characker)
1 workspace 7 Selected Resourees
» To start search: vty ——

» Select Search = Search...
from the menu

» Choose search criteria —— .

» Click Search
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Search Results

» Displayed in a Search View

» Double-click on an item in a view opens an
editor on that item

» Search Views allows for sorting and next
search

34 om| S

IyFirstProject{MyFolder/myFile.txt
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Preferences Dialog

» Used for

=loix|
R g = J workbench
C u Sto m I Z a t I O n E. ;D.:d Order I¥ Perform buld sutomatically on resource madfication
- t h E | - [ Debug I™ 3ave all modified resources automatically prior to manual build
I n e C I p Se g :fs‘fawupdate I Refresh Workspate on startup
. B Java I Confirm exit when closing last window
> Fo r Settl n g user g :\:;;mm Developmert [ Show Tasks view when buld has errors or warnings
pre ferences workspace save rtarval (nminutes); [5
~Open mode
» Opens by el
. S
selecting
. aran ke
WI n d OW 9 Mote: This preference may not take effect on all views
Preferences from et tats | el
th € menu Impart... Exqurt... Cancel
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Module Road Map

= QOverview
= Installing and Running
=  Workbench

= Building and Running Java Classes
* Developing Java applications
* Browsing Java code
* Searching Java code
* Using Code Assist
* Running Java applications
» Scrapbook
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Java Development Tooling - JDT

» Eclipse’s Java Development Environment is
often referred to as JDT - Java Development
Tooling
» Using the JDT you can do following with the Java

programs:
> Write
> Compile
> Test
> Debug
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Perspectives

» When developing Java code commonly used
perspectives are:
» Java Perspective
» Designed for working with Java projects
» Java Browsing Perspective
» Designed for browsing structure of Java projects
» Java Type Hierarchy Perspective
» Designed for exploring type hierarchy
» Debug Perspective
» Designed for debugging Java programs

feclipse
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» Contains:

Java Perspective

aix
> Edltor area Ele Edt Navigate Search Project Bun Window Help
IF-HEa|t-%-&-[adde e | e~
4 PaCkage g Package Explorer w3 || | Welcome Ema“_ XI |EE Outline %
i | iFversionz = }C\r\outlineisnot

E?(plorer % e MyFi’st%JE: svaiale,
View =

» Hierarchy
View

» Outline View - o

%7 Tasks (2 ikems)

TRy x

> TaSkS V|eW [¥] * [ pescription [ Resowce [ In Folder
B cenerc task
Bl Work on Ehis later mFile bk MyFirstProject fMyFoldar
Package Expl... |Hisrarchy | [ 4] | »
Wirikable [nsert 19

feclipse
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Java Browsing Perspective

» Contains:

Java Type Hierarchy Perspective

» Contains editor area and Hierarchy View

L 1ol x]

Eile Edt Source Refactor Mavigate Search Project Run Window Help

R
5k ¥

ﬁﬁw‘. -
NIRRT

& =@ object 5

R c
E; il AbstractFilter

[l o b & - |8 2 (% = -

- | elcome T | myFile.txt T ] String.c... ‘ [ out...
Class File Editor

| TS

RER
. fls Edt Source Refactor Navigate Search Project Run Window Help
» Editor area B HEE[Hs - k- -oapge-|es|ca-= B E
. ) B | profects v x ||y Packages = ] = x |55 Members =
> PrOJeCtS V|eW 5|5 W mrrsserops || @ jauang = |0z P |
@ (il 1t Jar - CHOKIEKLS | 6 java tang ref @F StringBuffer o valie =
P k 5 (i sunrsasian.jer - CH | B35y Jang reflect 4@ swingindextutofsoun o e
3 java.math @F system -~ count
> aC ages =] 3 java.net @ Terminator - o hash
V' B javarmi ~||® thread wf| o o fbrctonverter ¥
ew 4 TR [T | IR I | | '
. welome | jmyfietae | [ string.cless (X |
» TypeS VleW Class File Editor —
» Members
VI eW The jar file rt.jar has no source attachment,
You ean attach the source by dicking Attach Source below:
I I e
Javanlang.String - C:)jdkdjok1.3.1_DEYibtt jar

feclipse
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leclipse

E- G BytefrrayOutputStrean
L @F croazoutputstream
4] |
@* cutputstream
Hlhllas e
® © outputstream()
® dosel)
@ flushi)
© write(bytelT)

|+

© write(bytel], int, int) (]

Source not found

The jar file tt.jar has no source attachment.

You can attach the source by clicking Attach Source below:

attach Source. .

abstract public class java.io,OutputStream extends java.la

public java.io, OutputStreami);

Iabstract public void write(int arg) throwsi]ava.\o.IOExce 5
3

java.io.OukputStream - Crljdkiidkl.3.1_08tiblrt jar

‘Read Qnly |Insert

Jres
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New Project Preferences Creating Java Project

» You can set global N — BT » Project used to organize e

preferences for a project resources (source, class, = ﬁ
» Select Window -> Preferences || icons) for a project

to get Preferences View S » To create Java project: M
» Good idea to separate your il » Select Window = New > Sinple

Java files into source and // : Project... from the menu

compiled directories (src an i » The New Project wizard

bin) it comes up
» This action only ne Select Java - Java Project

done once i » Click Next
» Done for all subsequent Eeaie| &6 |

projects o | e e

s [ wets | gl | concel |
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New Project Wizard Java Settings

» Specify Project & » Specify Java settings . -

Java Project

Name P — 3 » Output folder (where """ B
com plled files will be (5 shiree | @ Broests| Wl Ubrarins | 11 Grder snd Expart |

} C I | C k N e Xt Project nams: |HeH0Ww\dFrU1ect| sto red ) AR and class Folders on the build path:

- BraEt cartarts ) . -l IRE System Library [jdk1,3.1_06] Add JARS... I
¥ Use default > EXte rna I _] ar ﬂ | es Add External JARs... I

Directary: [ Clurstedipsel|edipse\workspace)HellowarldPraject Browss. DFOjeCt depends on e
» Classes from other addipary.. |
projects that are £ Closs Ealder.._|

referenced in the |
project e |

. . Defaul outpat Felder:
> C||Ck Finish HeloWarldPraject Browse. .

T Zhadh | e | Einish | Cancsl |

<gek | s [ mmsh | canel |
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Project Properties

Creating P

ackages

» You can change the Java build path at any

time

» Choose Properties from the context menu on the

project

[ 121 2 Euild P
£ Jawva Compiler

i+ Javadoc Location
i+ Java Tack Tags

£ Properties for HelloWorldProject _ (ol xj

| Tools Bulders
i

*- Project References

Java Build Path

(9 Source | G projects | M) Lbrarkes 11 Order and Export |
Build dlass path order and exparted entries:

‘Exported entries are contributed to dependent projects)

H i HelowordProject Up |
i IRE System Library [jdk1.3.1_06]

Select Al
Deselect Al

Default output Folder:

[ HellowieridProject

Bramse.

e

feclipse
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» Package contains
Java class files

£- New Java Package x|

Java Package

Create 3 Java package. %

» To create a package
for a project:
» Select the project

» Choose New - Package
from the context menu

Specify package name
» Click Finish

v

Creates folders corresponding to packagss.
Browse. ..

Seurce Folder: [ HeloWarldProject

Mame: I com. espirity. course. demo

|

feclipse
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Creating Classes

» To create a class in
a package:
» Select the package

» Choose New - Class
from the context

menu
» The Class wizard
comes up

» Specify class details
» Click Finish

feclipse

£~ New Java Class il

Java Class

x.

Create a new Java class,

Browse. .
Browse. ..
Browse, .

Source Folders | HeloworldProject

Package: | com.espirity course. demo

I~ Enclosing typs: |

Mame: [ Helloworld
Modifiers: 1+ public Cdefaglt € private. € protected
I~ abstract T final = static
Superclass: | jova.lang.Object Browse, ..

Interfaces: Add..

Heriove

Which method stubs would you fike to create?

[ Constructars from superclass
¥ Inherited abstract methods
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Using Cod

e Assist

» When activated, code assist opens a list of

available code completions

» Code Assist activates by Crtl+Space

» Activates automatically when

a message needs to be sent

to an object (after the dot is typed)

£ Java - HelloWorld.java - Eclipse Platform —{of x|

Fle Edt Source Refactnr Mavigste Search Project

Run Window Help

(B -BEa [t k-5

e e 2% -

|2 % &

|| wekome | myFilebct W x|

= EE Ziny
Tl # @author Espirity

(=1

o |

EJ public class HelloWorld {

System.out.|

¥

leclipse

public static void main(String[] args) {

5 @ printin(Oblect a0} void - PrintStream A
© printin{String 3rg0) void - PrintStream

i © tostring() String - Object
7—-‘— © waitf) void - Object

@ waitflong argl) woid - Object:
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Using Quick Fix

» Useful if Java compiler shows errors
» Gives options for fixing the errors
» Activated through Edit > Quick Fix menu option

Error indication
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Searching for Java Classes

» When developing Java application a good search
mechanism is very important

» You often search for class, method declarations, and
references

» Itis important to be able to find things quickly
» Eclipse Java Search mechanism is very extensive
» It allows you to search for:

» Types, methods, constructors, packages, and fields

» Declarations, Implementers, References

» In the scope of Workspace, Working Set, or Selected
Resources
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Organizing Java Code

» Eclipse comes with extensive support for
organizing and refactoring Java code
» It is possible to:
» Generate getters and setters for the fields
» Organize missing import statements
» Move fields, methods, classes
» Rename methods, classes, packages
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Generating Getters and Setters

» Available for creating get and set methods
on the fields
» It supports encapsulation

» Activated by choosing Source - Generate Getter and
Setter from the editor’s context menu

getHello)
Lo e setHella(String)

i 2 methods selected.
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Refactoring

» Available from the Refactor context menu option in
the editor

» Helps with refactoring Java code

» Allows for:
» Renaming

> Methods, fields, packages, projects, parameters, or local
variables

Changing of method signature

Pull up a field or method (into super class)
Push down a field or method (into sub class)
Encapsulate field (generate getter and setter)

v v.v Vv

A Berief Introduction to Eclipse Project 81

Running Java Classes

» To Run Java application
» Choose Run = Run... from the menu

x
Create, manage, and run configurations ‘
Hame: | Hellowiorld
@ main |0<): arguments | Wl R | T4 Glasspath | E1 source | $§ common |
Praject:
| HelloworldPraject Brow:
Marr ¢lass:
| com.espirity .course. demo, Helloworld Search...
™ Inchude exkernal jars when searching For a main class
I Stopin main
Hew Delete Al Heyert
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Console View

» Represents standard Java console

» Opens by default when standard Java output
is used
» Can also be open from Window - Show View menu

System.out.println("Hello World");

Console [<terminateds =

|Bk -8 &
Hello World =]

4 o
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Scrapbook...

» Allows for writing and executing of Java code
» Very useful for quick test of Java code that you
write
» The Java code in the Scrapbook can be:
» Displayed as a string when evaluated

» Inspected when evaluated

> Opens an Inspector view where you can see returning
object from evaluation and all containing fields

» Executed
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...Scrapbook...

» It is created by
selecting a project and
choosing New -
Scrapbook Page from the
Package Explorer’s

context menu and ther/ =
entering the name of :

the page
» Your scrapbook page

will become a resource

in your project

feclipse

_

CLIAESATE
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» To open the scrapbook
page just click on the
resource

» It opens up like a Java
source file editor

» Type Java code and
select the context menu
to Display or Inspect

feclipse

apbook. jpage - Eclipse Platform
Search Project Bun Window elp

oK% &8P -
\ Elfix B =

XL,

... Scrapbook...

fin cutlin
valable,

s not
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...Scrapbook

» Class names must be fully
qualified in what you type

» Set imports to make life
easier

» Think of your scrapbook as a
page that Eclipse will take
the source you type, wrap it

in a class with your source in

the main menu, then
compile and execute

feclipse

& Java Snippet Imporis @

Manage the Java Snippet Editor Imports for "DemoScapbook.jpage”

Add Packages...

O Cancel
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